Kezdőoldal > Windows Server > AD leallas

AD leallas


Adva van egy hibas switch, amely annyiban mukodokepes, hogy komotosan ellatja a feladatat, de minden kiengedett csomag elott ketszer is meggondolja, hogy tenyleg kiengedje-e… No meg adva van egy szerver, melynek egyik laba mar megadta magat (megiscsak halozati kartya csere is lett a http://asteriksz.spaces.live.com/blog/cns!4072207D600A5106!204.entry problemabol).
 
Mivel nem tudtam, hogy az alaplapi halozati kartya vagy a kapcsolo rossz, kezdtem az egyszerubbel: kolcson switch. Ami konnyen keritheto volt, az egy regi Symantec tuzfal, melynek a WAN portja mukodeskeptelen. Remeltem, hogy attol meg a 8-portos switch resze el tudja latni a feladatot. Kabelek atdugva, s ime, maris korrekt sebesseggel mukodott a halozat.
 
A gond ott kezdodott, amikor a szervert ujrainditottam. Indulasnal kapasbol jelezte, hogy ip-cim utkozes van a halon. Sejtettem, hogy valami turpisag van a dologban, s kiderult, hogy a switch sajat belso ip-cimevel utkozik. A gond viszont ott volt, hogy a Symantec kezelofeluletet nem lehetett elerni (kozvetlenul laptoprol sem), s ezaltal nem lehetett atirni az ip-cimet. A szerveren nem akartam (SBS – tehat egy csomo helyre ez az ip-cim lett beirva). Ideiglenesen visszadugtam a rossz switchbe, hogy attol meg legalabb mukodokepes legyen a gep. Igen am, de ezek utan tovabbra sem volt ip-cime annak a kartyanak. Probaltam letiltani, majd ismet engedelyezni – ez utobbinal mindenfele furcsa hibauzenetet irt ki, ezert ismet ujrainditas mellett dontottem.
 
Miutan teljesen elindult a szerver, visszadugtam a rossz kapcsoloba – gondolva, hogy amig megjon a vegleges, uj switch, addig (termeszetesen ujrainditas nelkul) mukodni fog. Kiprobalva, valoban a halozati megosztasok elerhetoek voltak, de nehany szolgaltatas (pl. Exchange, SQL Agent, stb.) nem indult el. Mivel nem szeretem a felkesz allapotokat, elkezdtem kibogozni az esemenynaploban talalhato hibakat, hogy mi is lehet a gond. Ennek kovetkezmenye ismet ujrainditas lett – s ezutan
kezdett melegem lenni.
 
Ujrainditasnal ugyanis kb. 20-30 percig kellett varjak, amig megjelent az asztal. Ezutan raadasul a file-megosztasok sem voltak elerhetoek, mivel a szerver nem tudott hitelesiteni. ADUC-ot nyitva az a hibauzenet fogadott, hogy nincs hitelesitesi kiszolgalo. Egyszoval: pont a lenyeget, a szerver funkciojat vesztette el a gep. Gyakorlatilag egy darab vas, Windows-al.
 
A naplokbol elkezdtem korbejarni a Hiba tipusu esemenyeket. Ennek kovetkezteben elobb LanmanServer, majd DNS fuggove tettem a Netlogon szolgaltatast (utobbi KB259277 alapjan). Mivel nem voltam biztos benne, hogy nem-e DNS problema, kiprobaltam azt a megoldast is, amikor a DNS nem AD-integralt. Nehany kiserletezes utan termeszetesen ujrainditas valt szuksegesse, ilyenkor termeszetesen a bo felora varakozas is tovabb orolte az idegeimet.
 
Az esemenynaplot ismet atbongeszve igazi ertelmes "Hiba" bejegyzeseket – amik az okra utaltak volna – nem talaltam. Tehat eddig amik voltak, azokat legalabb sikerult megszuntettem. Okozatra (pl. Exchange nem indul) volt egy csomo – de ugye tudtam, hogy amig nincs egy AD-m, addig ezek nem is fognak megszunni.
 
Ekkor kezdtem el a Support Tools eszkozeit bevetni. Elsokent kapasbol a Dcdiag johetett szamitasba, ami egy Ldap bind error 31-et vagott felem. Sebaj, letezik a KB329873, hatha ez rendbeteszi. No igen, meg egy restart. Kutyagumi. Ujbol megprobaltam, ezuttal a rovid tartomany-nevvel. Ujabb ujrainditas utan ismet beintes lett az eredmeny, s a bejelentkezesi ido sem csokkent…
 
Kovetkezo jatekos a Netdiag volt. Itt mar Error_domain_controller_not_found fogadott, majd ennek kapcsan elindulva derult ki, hogy KB316710 alapjan a Kerberos szerviz le volt tiltva. Elindit – lett AD. Biztonsag kedveert ujrainditas – s ime, megfelelo ido alatt elindult… De hogy mi tiltotta le? Amikor IP-utkozes volt, akkor kerult ebbe az allapotba? Nem tudom… S oszinten szolva nem is nagyon akartam vele kiserletezni…
 
Ujrainditas utan tunt fel, hogy egy csomo figyelmezteto bejegyzes is megszunt a hibanaplobol. Eleinte a rossz switchnek tudtam be oket, de most megneztem kicsit tuzetesebben: MrxSmb 3034 hibak, c000005e = "STATUS_NO_LOGON_SERVERS" hibakoddal. Mivel csak figyelmeztetesek voltak, eddig nem tulajdonitottam nekik nagy figyelmet. Pedig ha ennek is utanajarok, lehet, hogy hamarabb megtalalom a hibat, hiszen ennel is kerek-perec irjak, hogy az egyik lehetseges ok a Kerberos szerviz. Dehat… elobb ugye a Hiba tipusuakat probaltam megoldani.
 
Ismet egy bo napos izgulas… S mindez egy hibas switch, majd egy meg hibasabb tuzfal miatt…
Advertisements
Kategóriák:Windows Server
  1. Tako
    november 14, 2007 - 4:43 du.

    azért ez kemény! gondolom mindez nap közben, szóval a telefon is csöngött egyfolytában hogy mi van!?Remélem ebből az esetből nem csinálnak mcp vizsga kérdést :)Egyébként meg ennyi hibánál baromira nem egyszerű megtalálni a rengeteg leírás alapján a hiba forrását. eventid is baromi jó de jó sokszor jó kis móka végig olvasni/gondolni a leírtakat

  2. Asterix
    november 15, 2007 - 7:15 de.

    Igazibol nem a felhasznalokkal volt baj, azok eleg konnyen megertettek, hogy "nincs szerver".
    A gond viszont ott volt, hogy az utolso pillanatig, amig nem talaltam meg a megoldast, nem tudtam, hogy mi fog kisulni belole… Mar kezdtem azon gondolkozni, hogy Authoritative restore lesz belole…
     
    A blogod nem nyilvanos?

  3. Tako
    november 18, 2007 - 8:01 du.

    privát üzenetben válaszoltam

  1. No trackbacks yet.

Vélemény, hozzászólás?

Adatok megadása vagy bejelentkezés valamelyik ikonnal:

WordPress.com Logo

Hozzászólhat a WordPress.com felhasználói fiók használatával. Kilépés / Módosítás )

Twitter kép

Hozzászólhat a Twitter felhasználói fiók használatával. Kilépés / Módosítás )

Facebook kép

Hozzászólhat a Facebook felhasználói fiók használatával. Kilépés / Módosítás )

Google+ kép

Hozzászólhat a Google+ felhasználói fiók használatával. Kilépés / Módosítás )

Kapcsolódás: %s

%d blogger ezt kedveli: